Scheduled Maintenance
Scheduled for Jan 2, 2025, 16:00 - 18:00 CET
Update
We will be undergoing scheduled maintenance during this time.
Posted Dec 20, 2024 - 09:41 CET
Scheduled
We will be undergoing scheduled maintenance during this time.
Posted Dec 20, 2024 - 09:39 CET
This scheduled maintenance affects: Outlook/To Do Sync Service, Allocatus API, Web App, and Teams Sync Interface.