Verification is currently underway for the maintenance items.
Posted Feb 27, 2025 - 17:59 CET
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 27, 2025 - 15:00 CET
Scheduled
We will be performing scheduled maintenance on our systems. During this window, the listed components may experience slower response times. We appreciate your patience and understanding as we work to improve our services.
Posted Feb 20, 2025 - 13:52 CET
This scheduled maintenance affected: Outlook/To Do Sync Service and Web App.